update installation for OCaml
[lambda.git] / how_to_get_the_programming_languages_running_on_your_computer.mdwn
index 426b53a..b75068f 100644 (file)
@@ -274,19 +274,28 @@ The current version of OCaml is 4.02.1 (released October 2014).
 
 *   **To install on Mac without MacPorts**
 
 
 *   **To install on Mac without MacPorts**
 
-    The people in charge of OCaml (they're at the French research institute INRIA) have stopped making pre-built packages for Mac OS X. One option you have is to use their package for a slightly older version of OCaml, 4.01.1 from Sept. 2013. You can find that as a "Precompiled binary for Mac OS X" on [this page](http://ocaml.org/releases/4.01.0.html).
+    The people in charge of OCaml (they're at the French research institute INRIA) have stopped making pre-built packages for Mac OS X. One option you have is to use their package for a slightly older version of OCaml, 4.01.1 from Sept. 2013. You can find that as a "Precompiled binary for Mac OS X" on [this page](http://ocaml.org/releases/4.01.0.html). If, when you attempt to install this package, you get an error about its being from an "unidentified developer," you need to control-click on the `ocaml.pkg` file and select "Open", then when the warning box appears again, this time there will be an "Open" button that you can click. Then you can continue running the Installer.
 
     A second option is to install the OPAM package manager and use that to build and install the latest version of OCaml. Here's how to do that:
 
 
     A second option is to install the OPAM package manager and use that to build and install the latest version of OCaml. Here's how to do that:
 
-    1.  Download [this file](https://raw.github.com/ocaml/opam/master/shell/opam_installer.sh) and note where it gets saved to.
+    1.  Download [this file](https://raw.github.com/ocaml/opam/master/shell/opam_installer.sh) and
+    note where it gets saved to. If it opens in your browser, then type
+    command-S / Save Page and save it somewhere on your disk, again noting its
+    location.
 
     2.  Open a terminal and type:
         
             sudo mkdir -p /usr/local/bin
 
     2.  Open a terminal and type:
         
             sudo mkdir -p /usr/local/bin
-            sh /path/to/opam_installer.sh /usr/local/bin
+            sudo sh /path/to/opam_installer.sh /usr/local/bin
 
         Except replace `/path/to` with the real location, that you noted in step 1.
 
 
         Except replace `/path/to` with the real location, that you noted in step 1.
 
+    3.  If that works, then type:
+
+            opan init --comp 4.01.0
+
+        or whatever it was that the OPAM installer prompted you to type. This will download and install a fresh version of OCaml, and will take a bit of time.
+
 <!--
 If you do have Xcode, and want to do without MacPorts, then
 what you need to do is download Findlib from
 <!--
 If you do have Xcode, and want to do without MacPorts, then
 what you need to do is download Findlib from
@@ -343,9 +352,6 @@ double-click and install.
     you a nice history of the commands you've already typed, which you can scroll up and down in with your
     keyboard arrows.
 
     you a nice history of the commands you've already typed, which you can scroll up and down in with your
     keyboard arrows.
 
-**After using any of those methods**, if you managed to install OPAM along with OCaml, then open a Terminal and type this:
-
-    echo "will be posted shortly"
 
 
 ## Getting Haskell ##
 
 
 ## Getting Haskell ##