update installation for OCaml
[lambda.git] / how_to_get_the_programming_languages_running_on_your_computer.mdwn
index 0275051..848bd52 100644 (file)
@@ -229,17 +229,14 @@ Sometimes we may refer to Caml or ML
 more generally; but you can assume that what we're talking about always works more
 specifically in OCaml.
 
-It's helpful if in addition to OCaml you also install the Findlib add-on.
-This will make it easier to install additional add-ons further down the road.
-However, if you're not able to get that working, don't worry about it much.
+It's helpful if in addition to OCaml you also install the
+Findlib add-on and/or the [OPAM](https://opam.ocaml.org) "package manager."
+These will make it easier to install additional add-ons further down the road.
+However, if you're not able to get them working, don't worry about it much.
 
 The current version of OCaml is 4.02.1 (released October 2014).
-
 <!-- 3.12.1 July 2011; 4.00.1 Oct 2012; 4.01.0 Sept 2013; 4.02.0 Aug 2014; 4.02.1 Oct 2014 -->
 
-*   *Another instruction page focuses on [OPAM](http://ocaml.org/docs/install.html), also [this](https://opam.ocaml.org).*
-
-*   *[More details about installing OCaml on Macs, if needed](http://cocan.org/getting_started_with_ocaml_on_mac_os_x)*
 
 *   In your web browser:
 
@@ -248,7 +245,9 @@ The current version of OCaml is 4.02.1 (released October 2014).
 
 *   **To install in Windows**
 
-    Go to <http://caml.inria.fr/download.en.html>.
+    There are *five* different strategies for installing OCaml on Windows. I don't know which works best.
+
+    1.  First, you can go to <http://caml.inria.fr/download.en.html>.
     You can probably download and install the
     "Self installer for the port based on the MinGW toolchain"
     even if you don't know what MinGW or Cygwin are.
@@ -257,17 +256,33 @@ The current version of OCaml is 4.02.1 (released October 2014).
     At the time of this writing, only an installer for an earlier
     version of OCaml (4.01.0, from September 2013) is available.
 
-    To install the Findlib add-on, you must have the
-    Cygwin system installed. We assume few of you do,
-    so we're not going to try to explain how to do this.
+    2.  A second strategy uses a package called
+        [OCPWIN](http://ocaml.org/docs/install.html#OCPWINSelfContainedOCamlforWindows). This also installs only version 4.01.0.
+
+    3.  The [three remaining strategies](http://ocaml.org/docs/install.html#OCamlonCygwin) in some way
+    use the Cygwin environment, mentioned earlier on this page. At least one of
+    those three methods will automatically fetch and help you install Cygwin.
+    The first method listed on that page says it installs version 4.00.1, but
+    really it's been updated and now installs the (somewhat newer, but still
+    not the newest) version 4.01.0.
+
+    Some of these methods may automatically install Findlib for you. If not,
+    you can try installing it yourself but I think you'll need the Cygwin
+    system installed to do so. I'm not going to explain how to do this.
     If you want to figure it out yourself, go to the
     Findlib website at <http://projects.camlcity.org/projects/findlib.html>.
 
 *   **To install on Mac without MacPorts**
 
-    *Instructions coming*
+    The people in charge of OCaml (they're at the French research institute INRIA) have stopped making pre-built packages for Mac OS X. One option you have is to use their package for a slightly older version of OCaml, 4.01.1 from Sept. 2013. You can find that as a "Precompiled binary for Mac OS X" on [this page](http://ocaml.org/releases/4.01.0.html).
+
+    A second option is to install the OPAM package manager and use that to build and install the latest version of OCaml. *Instructions on how to do that will be posted shortly.*
+
+<!--
+    *Another instruction page focuses on [OPAM](http://ocaml.org/docs/install.html), also [this](https://opam.ocaml.org).*
+
+    *[More details about installing OCaml on Macs, if needed](http://mirror.ocamlcore.org/wiki.cocan.org/getting_started_with_ocaml_on_mac_os_x.html)*
 
-    <!--
     To install OCaml 3.12 (just released this summer), go to
     <http://caml.inria.fr/download.en.html>
     and download and install the "Binary distribution for Mac OS X"
@@ -373,7 +388,33 @@ On **Ubuntu or Debian Linux**:
 *   In a Terminal, type `sudo apt-get install haskell-platform`.
 
 
-If any of the instructions above don't work, then you can try alternative instructions for [Mac](http://new-www.haskell.org/downloads/osx) or [Windows](http://new-www.haskell.org/downloads/windows) or [Ubuntu](http://new-www.haskell.org/downloads/linux). After installing the software, open a Terminal and type `cabal update && cabal install alex happy`. <!-- If typing `which ghci` in a Terminal doesn't give you any reply, you may need to type `echo 'export PATH=/usr/local/bin:$PATH' >> ~/.bashrc`, then exit and restart your Terminal session. --> Note that this method doesn't install all the extensions that are part of the Haskell Platform, but only the core pieces of GHC. You can use Cabal to download and manage any extra extensions you turn out to need, down the road.
-
 It's useful to know about the general [Haskell wiki](https://wiki.haskell.org) (not restricted to just GHC). They have a [Getting Started](https://wiki.haskell.org/Haskell_in_5_steps) page, which also recommends that you install the Haskell Platform.
 
+If any of the instructions above don't work, then you can try alternative instructions for [Mac](http://new-www.haskell.org/downloads/osx) or [Windows](http://new-www.haskell.org/downloads/windows) or [Ubuntu](http://new-www.haskell.org/downloads/linux). Note that this method doesn't install all the extensions that are part of the Haskell Platform, but only the core pieces of GHC. You can use Cabal to download and manage any extra extensions you turn out to need, down the road.
+
+**After installing Haskell**, open a Terminal and type:
+
+    cabal update
+
+It may give you a message about updating your `PATH` variable. On my Mac, I first typed `echo $PATH` and verified that `/usr/local/bin` appeared somewhere in the resulting string. (The elements are divided by `:` characters.) Then I typed this:
+
+    echo 'export PATH="$HOME/Library/Haskell/bin:$PATH"' >> ~/.bash_profile
+
+That was to update my `PATH` variable as instructed by Cabal. On a Linux machine, or if you installed Haskell differently on your Mac, you might have to type instead:
+
+    echo 'export PATH="$HOME/.cabal/bin:$PATH"' >> ~/.bash_profile
+
+Some instructions may say to use `.bashrc` instead of `.bash_profile`. These files do similar jobs.
+
+After issuing the relevant `echo` command, I exited the Terminal and started a new Terminal session. Now if I type `echo $PATH` I should see the directory I just added in the list. Now I can contine setting up Cabal. I type:
+
+    which alex happy
+
+If that gives me back two pathnames, one to the program `alex` and the other to the program `happy`, then I'm already finished. If not, then I type:
+
+    cabal install alex happy
+
+This installs those two programs. They are helpers that Cabal needs to build and install some packages.
+
+<!-- https://github.com/pittsburgh-haskell/haskell-installation -->
+